aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDerek Lamberti <derek.lamberti@arm.com>2020-02-19 13:30:47 +0000
committerDerek Lamberti <derek.lamberti@arm.com>2020-03-09 09:17:21 +0000
commit4d4e0e2530629ae9ecfcb379bf0f27c6b18b6891 (patch)
tree5240428061fe5c57ce1c762908166432bca7d0c5 /CMakeLists.txt
parente66448491b836049df62e63e1e5151eefe3bfcf8 (diff)
downloadarmnn-4d4e0e2530629ae9ecfcb379bf0f27c6b18b6891.tar.gz
IVGCVSW-4483 Introduce polymorphic_downcast implementation
Change-Id: I958dd719162337eb5c7e71f4ac49dd5784564b1a Signed-off-by: Derek Lamberti <derek.lamberti@arm.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2f8761aa94..046ef834ec 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -249,6 +249,7 @@ list(APPEND armnn_sources
include/armnn/profiling/ISendTimelinePacket.hpp
include/armnn/utility/Assert.hpp
include/armnn/utility/IgnoreUnused.hpp
+ include/armnn/utility/PolymorphicDowncast.hpp
profiling/common/include/SocketConnectionException.hpp
src/armnn/layers/LayerCloneBase.hpp
src/armnn/layers/LayerWithParameters.hpp
@@ -648,6 +649,7 @@ if(BUILD_UNIT_TESTS)
src/armnn/test/TestNameAndDescriptorLayerVisitor.cpp
src/armnn/test/TestUtils.cpp
src/armnn/test/TestUtils.hpp
+ src/armnn/test/UtilityTests.cpp
src/armnn/test/UnitTests.cpp
src/armnn/test/UnitTests.hpp
src/armnn/test/UtilsTests.cpp